• Welcome to For E Bodies Only !

    We are a community of Plymouth Cuda and Dodge Challenger owners. Join now! Its Free!

ammeter gauge clicking

Challenger RTA

Well-Known Member
Joined
Oct 28, 2018
Messages
925
Reaction score
368
Location
PA Flood city
Just took it for a cruise to run an errand. Here is where the amp gauge was under high idle (cold engine). After running into Home Depot for Christmas lights (don’t get me started) the idle was back to low where it belongs and the meter was much closer to the center, but not dead center. When I give gas it goes closer to C. When the signal is on, the meter moves barely to toward the Do you have a stock ignition coil? excessive current charging coil when first turned on. would produce a noise. exceeding amp gauge limit.
Do you have a stock ignition coil? excessive current charging coil when first turned on. would produce a noise. exceeding amp gauge limit. From what I think understand. some after market coils come with a ballast resistor to limit voltage or current. that could be the noise on the discharge side.or voltage limiter on gauge cluster going bad. just thought I would put that out there.
 

VillaTA

Well-Known Member
Joined
Aug 18, 2021
Messages
148
Reaction score
21
Location
Cincinnati
Do you have a stock ignition coil? excessive current charging coil when first turned on. would produce a noise. exceeding amp gauge limit. From what I think understand. some after market coils come with a ballast resistor to limit voltage or current. that could be the noise on the discharge side.or voltage limiter on gauge cluster going bad. just thought I would put that out there.
I had the coil, ballast, and electronic ignition box replaced.
 

Challenger RTA

Well-Known Member
Joined
Oct 28, 2018
Messages
925
Reaction score
368
Location
PA Flood city
As far as gauge going charge side too much. What's to much.Gauge going bad? Battery low on charge.When a battery is made is takes days to charge. I'm saying 24 48 to 72 hours depending on the battery,to fully charge.It's greater amount of time then what one would think.Battery is slowly charged so electrolyte is not boiled of and burn the plates.Alt charging battery? short in battery? Alt putting out to much voltage? check the gravity in the battery. If the cells read ( say cells read low 1225 to high 1275 OK) anything more than 50. battery going bad. stock size pulley on alt?
 
Last edited:

Challenger RTA

Well-Known Member
Joined
Oct 28, 2018
Messages
925
Reaction score
368
Location
PA Flood city
When I turn on my key before starting the engine my ammeter indicator keeps clicking towards the negative side also when I hit the turn signal on one side it also faintly flashes on the opposite side with the rhythm of the ammeter not sure what's going on. I have been reading about problems with the ammeter causing fires should I disab
Did you try pulling both frashers and replacing? This year after 50 years mine went bad.Go figure!
 

marks ebody

Well-Known Member
Joined
Feb 27, 2015
Messages
301
Reaction score
44
Location
Ventura California
I just installed a new under dash loom in a 70 cuda.
and it doesn’t make any clicking noise when the key is turned on so I took pictures of it, you might want to ck your wiring with this one.
Also installed a new NOS Ignition Switch
 

Attachments

  • A63B5475-2F7A-4F8F-B9A3-F24BA04A18E7.jpeg
    A63B5475-2F7A-4F8F-B9A3-F24BA04A18E7.jpeg
    277.1 KB · Views: 49
  • 88149470-5CA2-4C8D-9F7A-32D05860D4E7.jpeg
    88149470-5CA2-4C8D-9F7A-32D05860D4E7.jpeg
    214.3 KB · Views: 52
  • 6FD4CEA6-114F-4DEB-87FC-17AC8E7CD7FD.jpeg
    6FD4CEA6-114F-4DEB-87FC-17AC8E7CD7FD.jpeg
    326 KB · Views: 50

340 Slapstick

Well-Known Member
Joined
Oct 1, 2021
Messages
48
Reaction score
17
Location
St Louis Missouri
I just installed a new under dash loom in a 70 cuda.
and it doesn’t make any clicking noise when the key is turned on so I took pictures of it, you might want to ck your wiring with this one.
Also installed a new NOS Ignition Switch
How difficult was it to replace the firewall bulkhead connector?
 

fasjac

Well-Known Member
Joined
Dec 27, 2019
Messages
1,779
Reaction score
899
Location
Arkansas
When I turn on my key before starting the engine my ammeter indicator keeps clicking towards the negative side also when I hit the turn signal on one side it also faintly flashes on the opposite side with the rhythm of the ammeter not sure what's going on. I have been reading about problems with the ammeter causing fires should I disable it ?
Just a thought but, get a new flasher relay if you haven’t already.
 
Top